ystem libzip must be upgraded to version >= 0.11 linux编译安装libzip-1.5.2

             

今天给php安装zip扩展时,遇到以下错误

system libzip must be upgraded to version >= 0.11

根据提示我们可以清楚的知道是因为系统自带的 libzip 版本低了,这里我们需要安装最新的 libzip-1.5.2

下载地址 https://libzip.org/download/

解压

tar -zxvf libzip-1.5.2.tar.gz
cd libzip-1.5.2

编译安装(没有安装cmake点击这里

mkdir build
cd build/ 
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/libzip .. 
make 
make install

安装完成



发表评论 请登录再评论
回到顶部