ystem libzip must be upgraded to version >= 0.11 linux编译安装libzip-1.5.2

今天给 php 安装 zip 扩展时,遇到以下错误

system libzip must be upgraded to version >= 0.11

根据提示我们可以清楚的知道是因为系统自带的 libzip 版本低了,这里我们需要安装最新的 libzip-1.5.2

下载

解压

tar -zxvf libzip-1.5.2.tar.gz
cd libzip-1.5.2

编译安装

mkdir build
cd build/
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/libzip ..
make
make install

安装完成