1 背景 由于开发环境只有局域网,没法使用网上的各种 YUM 源,来回拷贝 rpm 包安装麻烦,还得解决依赖问题。 想着搭建个本地 ,方便自己跟同事安装软件。 2 环境[root@host-10-253-1-69 /]# cat /etc/redhat-release CentOS Linux release 7.5.1804 (Core) 并且是 Minimal Install。 3 安装本地 YUM 源3.1 准备 镜像, 挂载 CentOS-7-x86_64-Everything-1804.iso,把里面所有文件都拷贝到本地目录 / yum/yum-iso...
             
1、 这里我们来说下很重要的负载均衡, 那么什么是负载均衡呢? 由于目前现有网络的各个核心部分随着业务量的提高,访问量和数据流量的快速增长,其处理能力和计算强度也相应地增大,使得单一的服务器设备根本无法承担。在此情况下,如果扔掉现有设备去做大量的硬件升级,这样将造成现有资源的浪费,而且如果再面临下一次业务量的提升时,这又将导致再一次硬件升级的高额成本投入,甚至性能再卓越的设备也不能满足当前业务量增长的需求。 针对此情况而衍生出来的一种廉价有效透明的方法以扩展现有网络设备和服务器的带宽、增加吞吐量、加强网络数据处理能力、提高网络的灵活性和可用性的技术就是负载均衡(Load...
             
整个过程不需要卸载原先的 openssl 包和 openssh 的 rpm 包。如果严格参照本文操作,保证你升级没问题,今天升级了三台centos7.2 升级前后的对比1、进入正文,建议先安装 telnet-server 以及 xinetd,万一失败无法登录,还可以用telnet登录之前有写过这篇文章,这里就不详细说了,详情见链接:CentOS7 安装 telnet 服务2、升级需要几个依赖包,是和编译相关的yum install -y gcc gcc-c++ glibc make autoconf openssl openssl-devel pcre-devel pa...
             
系统信息arch #显示机器的处理器架构(1) uname -m #显示机器的处理器架构(2) uname -r #显示正在使用的内核版本 dmidecode -q #显示硬件系统部件 - (SMBIOS / DMI) hdparm -i /dev/hda #罗列一个磁盘的架构特性 hdparm -tT /dev/sda #在磁盘上执行测试性读取操作 cat /proc/cpuinfo #显示CPU info的信息 cat /proc/interrupts #显示中断 cat /proc/meminfo #校验内存使用 cat /proc/swaps ...
             
导出指定表结构(不含数据)mysqldump -u<user> -p<password> -d <database> <table_1> <table_2> > db.sql导出表结构和数据mysqldump -u<user> -p<password> <database> <table_1> <table_2> > db.sql 导出整个库的表结构和数据mysqldump -u<user> -p<password&...
             
原理和 docker php容器安装pdo_mysql扩展 差不多如果扩展中没有redis,则需要手动加入下载扩展放到容器中去:https://github.com/phpredis/phpredis/archive/3.1.3.tar.gztar xfz phpredis-3.1.3.tar.gz mv phpredis-3.1.3 /usr/src/php/ext/redis docker-php-ext-install redis //重启php容器 docker restart php
             
使用官方的php镜像安装了php7.3,然而php中没有默认安装pdo_mysql扩展,就需要手动安装,也可以放到docker-compose.yml的command中执行//进入php容器 docker exec -it php /bin/bash //安装php_mysql扩展 docker-php-ext-install pdo_mysql //退出容器重启容器 docker restart php
             
docker-compose启动docker-compose是docker三剑客之一,用来专门启动镜像的插件,可以通过pip install docker-compose安装。可以新建一个如下目录结构的文件夹,作为镜像的启动文件夹:编写docker-compose.yml文件(启动三个容器):version: "3.1" services: nginx: image: nginx:latest container_name: nginx working_dir: /application volumes...
             
环境:Centos 7.5 + Mysql 8.0.19 + python3.8先说说遇到的两个坑:1、PyMySQL 使用的版本必须是0.9.3binlog2sql 源码里 requirements.txt 指定的版本是0.7.11,后来尝试了最新版,最后翻了N偏帖子,有位兄弟说必须使用0.9.3,才得以解决2、UnicodeDecodeError: 'utf-8' codec can't decode byte xxx 此类错误将binlog2sql_util.py中的decode("utf-8")替换为<code>decode("utf-8","ign...
             
创建用户create user 'test1'@'localhost' identified by '密码'; flush privileges; 刷新权限 其中 localhost 指本地才可连接可以将其换成 % 指任意 ip 都能连接也可以指定 ip 连接修改密码Alter user 'test1'@'localhost' identified by '新密码'; flush privileges; 授权grant all privileges on *.* to 'test1'@'localhost' with grant option;with gran...
  •   文章分类
回到顶部